Cloudflare has implemented a fix, and all EcoPortal services have recovered. We will continue monitoring the situation for any further issues.
Posted Nov 19, 2025 - 03:40 NZDT
Monitoring
Cloudflare is working to recover the services.
Posted Nov 19, 2025 - 01:45 NZDT
Identified
Our CDN provider experienced a global outage, which caused all URLs served through the CDN to stop functioning. This impacted access to various EcoPortal services. We are actively monitoring the provider’s recovery and will update this page as more information becomes available.
Posted Nov 19, 2025 - 00:50 NZDT
This incident affected: Web APP, Mobile, Frontend application, and Cloudflare Network.